[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Setting up pbuilder or sbuild like experimental buildds


>  Then I thought I might have forgotten APT::Default-Release, and with
>  APT::Default-Release set to "unstable", I could pin experimental higher
>  than 500, 700 for example, and it wouldn't upgrade the packages
>  automatically, however it still doesn't work.
>  These are the scores of the package I'm interested in:
> bee# apt-cache policy libglib2.0-dev
> libglib2.0-dev:
>   Installed: 2.10.3-3
>   Candidate: 2.10.3-3
>   Version table:
>      2.12.0-1 0
>         600 http://ftp.de.debian.org experimental/main Packages
>  *** 2.10.3-3 0
>         990 http://ftp.de.debian.org sid/main Packages
>         100 /var/lib/dpkg/status
>  I checked the code of pbuilder-satisfydepends, and I see it tries all
>  versions of "apt-cache show" output to see whether one of them would be
>  enough, but I see no place where it would request a particular version.

Yup, that's not supported in current pbuilder-satisfydepends codebase.
You're welcome to submit a patch, however.

dancer@{debian.org,netfort.gr.jp}   Debian Project

Reply to: