[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#350468: libpcre3: install libpcre.so* in /lib



* Mike Hommey [Sat, 22 Jul 2006 12:34:21 +0200]:

> On Sat, Jul 22, 2006 at 12:27:16PM +0200, Marco d'Itri <md@Linux.IT> wrote:
> > Scripts using -P would need to depend on libcpre.

> But packages including such scripts and not depending on libpcre would
> be difficult to find...

Since grep has no -P support at the moment, there are no such scripts
now. Then, the changelog entry for the grep version that introduces it
can make it clear the need for the dependency by packages wishing to use
-P.

Since those maintainers will need to check the changelog to know what
version of grep they need to depend on, they'll see the comment and add
the libpcre dependency as well.

At the end of the day, I doubt the number of packages that introduce the
versioned dependency but not the dependency on the library will be
hopefully very low. There will be of course a number of packages without
either of those, but the versioned depends is needed whether dlopening
or not, so it doesn't sound like the number of buggy packages will be
bigger (if grep dlopens instead of just linking).

Cheers,

-- 
Adeodato Simó                                     dato at net.com.org.es
Debian Developer                                  adeodato at debian.org
 
Let us not be ashamed to speak what we shame not to think.
                -- Michel de Montaigne



Reply to: