[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Move to python 2.4 / Changing the packaging style for python packages



Le Mer 14 Juin 2006 15:23, Pierre Habouzit a écrit :
> Le Mar 13 Juin 2006 07:12, Anthony Towns a écrit :
> > Apps can do either:
> >
> >     Package: foo
> >     Depends: python (>= 2.4), python-bar
> >
> >     /usr/bin/foo: #!/usr/bin/env python
>
> doesn't it breaks if python-bar only provides 2.3 modules ? because
> in an apt PoV the dependencies will be fullfiled, but the application
> won't work for obvious reasons.
>
> the XS-Python-Version for that application would be >= 2.4 e.g., and
> that would mean that at package build time, one should ensure all the
> dependency chain *has* to provide at least one fully available chain
> (not necessarily 2.4, maybe 2.5 or higher ...).
>
> and if it breaks because at some point a secondary dependency does
> not provides one of the modules it was supposed to, apt won't see
> it's uninstallable, because real dependencies schemes do not match
> how they are projected into the apt ones, they are more subtle.

okay never mind, like Joss explained on IRC, python-bar Depends: python 
(<< 2.4) and that works. sorry for the noise.
-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpbk2ZrYdwHQ.pgp
Description: PGP signature


Reply to: