[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packages that need to be rebuilt agaisnt libssl0.9.8

On Thu, 06 Oct 2005, Nathanael Nerode wrote:
> martin@uni-mainz.de wrote:
> > But I don't think that versioning the
> >symbols in Debian alone would be such a good idea. Than we would be
> >incompatible with other distributions.

Then mail the other distro maintainers and upstream, they will listen to you
and it is actually probable you will not have much trouble with the other

Upstream might want a foolproof way to detect whether it should version
symbols or not (I suspect that when using libtool this is a no brainer: tell
libtool to version, and if the platform can't version, it should simply
ignore the request).

Debian can and often does lead the other distros re. versioned symbols.  It
is very troubling that openssl is still unversioned, and thus we have to
transition a lot of packages every time a new openssl hits the archive, OR
risk segfaults everywhere.

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Reply to: