[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITP: g-wrap -- Scripting interface generator for C

Andreas Rottmann <a.rottmann@gmx.at> writes:

> To clarify the situation: I've included mininimal wrappers for GLib
> that work with both GLib 1.x and GLib 2.x in G-Wrap, mainly to support
> GnuCash. These wrappers are built against GLib 1.x, since currently
> GnuCash/GNOME2 is not ready for prime-time, and GNOME2 programs
> written in Guile should use the bindings of GLib in guile-gnome
> anyway, since these are much more complete. When GnuCash/GNOME2
> finally arrives, either G-Wrap has to build the GLib bindings against
> GLib 2.x, or GnuCash has to switch to use guile-gnome.

It is simply not important to me to "get rid of things" for its own

I don't want to make potentionally destabilizing changes, and I
*especially* don't want to make changes like this which result in
upstream saying "you're totally on your own now."

I'm happy maintaining gwrapguile right now.  It's extremely stable and
isn't causing any problems that I know of.


Reply to: