[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-Depend'ing on libasound2-dev just for Linux

Lawrence Williams a écrit :

I am working on a package that Build-Depends on libasound2-dev, but can be built on non-Linux OSs. Is there any way to shape the Build-Dep so that libasound2-dev is only used if we are building for a Linux system?

I seen an example of a possible choice in xorg-x11 packages that Build-Dep on linux-kernel-headers, but I wasn't sure if I should follow their example:

linux-kernel-headers (>= 2.6.13+0rc3-1.1) [!hurd-i386 !netbsd-i386 !kfreebsd-i386]

In Debian, does this prevent it from building on anything other than Linux??

Currently this is the solution. In the future, dpkg should support build-depencies like [linux-any] or [any-i386]. See the bug #291939. I hope this support will be available soon.


  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian GNU/Linux developer | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: