[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mesag3 <-> xlibmesa-gl / libgl1-mesa-dri <-> xlibmesa-dri / libglu1-mesa <-> libglu1-xorg

On Thu, Sep 01, 2005 at 03:20:10AM +0200, Michael Biebl wrote:

 > x-window-system-core in Ubuntu Breezy now depends on
 > libgl1-mesa-dri/libgl1-mesa/libglu1-mesa while as in unstable it is
 > xlibmesa-dri/xlibmesa-gl/liblu1-xorg.

 If that's right, that's broken, too.

 It should at most recommend libgl1-mesa-dri | libgl1.  There's really
 no reason to pull OpenGL with the X Window System.  There are small
 systems which really don't need it.

 > I got the impression that this is an attempt to get a consistent
 > naming scheme as a first step in order to prepare for the
 > X11R6.9/X11R7.0 release. IIRC X11R6.9 and X11R7.0 will use an
 > installed mesa package to provide OpenGL functionality and will not
 > need it's own copy of mesa anymore.

 Probably, which in itself is not wrong.


Reply to: