[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: MIT krb5 vs. Heimdal for curl's GSSAPI support (Re: Who needs libcurl3?)

Domenico Andreoli <cavok@debian.org> writes:

> i'm not a kerberos guru, i never used it and probably i will never be
> interested in it. i added this package only after a debian user asked
> for GSSAPI support in curl (FYI bug #241553).

Got it. :-)

> anybody knows if curl will modify its behaviour switching to MIT krb5?

It oughtn't, though it looks like you need to edit debian/rules in
addition to debian/control:

diff -u curl-7.14.0/debian/control curl-7.14.0/debian/control
--- curl-7.14.0/debian/control
+++ curl-7.14.0/debian/control
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Domenico Andreoli <cavok@debian.org>
 Uploaders: Matthias Klose <doko@debian.org>
-Build-Depends: debhelper (>> 3.0.0), autotools-dev, binutils (>=, libssl-dev, zlib1g-dev, stunnel, heimdal-dev [!hurd-i386], libidn11-dev, groff-base, libdb4.2-dev
+Build-Depends: debhelper (>> 3.0.0), autotools-dev, binutils (>=, libssl-dev, zlib1g-dev, stunnel, libkrb5-dev [!hurd-i386], libidn11-dev, groff-base, libdb4.2-dev
 Standards-Version: 3.6.1
 Package: curl
diff -u curl-7.14.0/debian/rules curl-7.14.0/debian/rules
--- curl-7.14.0/debian/rules
+++ curl-7.14.0/debian/rules
@@ -46,7 +46,7 @@
 ifeq (${DO_GSSAPI},yes)
 	mkdir -p debian/build-gssapi
-	cd debian/build-gssapi && ../../configure ${CONFIGURE_ARGS} --with-gssapi-includes=/usr/include --with-gssapi-libs=/usr/lib
+	cd debian/build-gssapi && ../../configure ${CONFIGURE_ARGS} --with-gssapi=/usr
 	touch configure-stamp

Aaron M. Ucko, KB1CJC (amu at alum.mit.edu, ucko at debian.org)
Finger amu@monk.mit.edu (NOT a valid e-mail address) for more info.

Reply to: