Re: Excuses page showing incorrect dependencies
Roberto C. Sanchez <email@example.com> wrote:
> The excuses pages are showing that my vncsnapshot package is being held
> back for two reasons. First, it is only 4 of 10 days old, which is
> acceptable. Second, because it depends on gcc-4.0, which has RC bugs.
> However, I haven't specificed such a dependency.
> $ apt-cache show vncsnapshot |sed -n '/^Depends/p'
> Depends: libc6 (>= 2.3.2.ds1-21), libgcc1 (>= 1:3.4.1-3), libjpeg62,
> libstdc++5 (>= 1:3.3.4-1), zlib1g (>= 1:1.2.1), vnc-common
> Why is this?
Because you are only checking the iX86 version of your package.
libgcc1 (>= 1:3.3.4-1) [hppa]
GCC support library
libgcc1 (>= 1:3.4.1-3) [arm, i386]
libgcc1 (>= 1:4.0.0-7) [not arm, hppa, i386]
libgcc1 is now available in a new version, built from gcc-4 and a couple
of autobuilders have built your package /after/ that.
"See, I told you they'd listen to Reason," [SPOILER] Svfurlr fnlf,
fuhggvat qbja gur juveyvat tha.
Neal Stephenson in "Snow Crash"