[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Regarding XEN kernel images


I was able to get Xen running. But you need at least the 2.0.4-4 packages, as 
the -3 packages were missing the xen.gz code.

2nd: I tried your kernels but wasn't successful. I assume that it shouldn't be 
used for the Domain-0 as Xen seems to expect the kernels in ELF format...

This is how my grub menu.lst looks like (using the xen0 kernel from the xen 
kernel          /boot/xen.gz dom0_mem=131072
module          /boot/vmlinuz-2.6.10-xen0 root=/dev/cciss/c0d0p1 ro 

how do you use your kernels? just within domains>0?

thanks philipp
On Wednesday 16 February 2005 20.45, Raphael Bossek wrote:
> Hi Lars,
> I could today achieve a big step forward. I found a configuration that
> worked for k7 (AMD). I've also created a initrd file (manually) and booted
> with the Xen loaded. And here starts my problems. I was not able to boot
> because the ide-generic Linux driver dumps a segmentation fault :( I'll see
> what the xen-devel lists says.
> Until now I can say that there are some additional modification on the xen
> 2.0.4-3 required. I think also that the kernel-package will be updated.
> I'll see if I find the time to publish these patches on my server.
> It would be interesting to hear more about people who try the same and
> their expiriences with Xen.
> --
> Raphael Bossek

Reply to: