[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

New version of ipsec-tools


I have taken over as maintainer of ipsec-tools. I'll be soon uploading
ipsec-tools 0.5rc2 to unstable, skipping version 0.4 (0.3.3 is the latest
version in Debian). I would really like to get 0.5 into sarge because there
have been many enhancements to ipsec-tools (for e.g. NAT-T support, Dead
Peer Detection, support for PlainRSA keys for easy migration from FreeSWAN,
Hybrid authentication). This is also the first release that supports Linux
kernel versions 2.6.10 and above (FWD policy support).

Even though upstream considers it ready for production use, I'm planning to
file a bug to keep it out of testing for two reasons; first because the
packaging has been completely redone (using debhelper), so I want to make
sure I didn't break anything and second I expect at least one more release
candidate before the final release is made. I'll make an upload as soon as
0.3.3-7 gets into testing. 

If you're impatient, you can try my packages at

deb http://people.debian.org/~rganesan/packages binary/
deb-src http://people.debian.org/~rganesan/packages source/

Please test these packages if you are currently using ipsec-tools. Thanks.


Ganesan Rajagopal (rganesan at debian.org) | GPG Key: 1024D/5D8C12EA
Web: http://employees.org/~rganesan        | http://rganesan.blogspot.com

Reply to: