[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Updating scanners and filters in Debian stable (3.1)

On Mon, Oct 04, 2004 at 11:06:03AM -0400, Stephen Gran wrote:
> So, now that this thread has been going on for a little while, I wanted
> to see what the consensus among RM's is:  are we going to allow updates
> for these programs in sarge or do we have to resort to out of band
> updates, like volatile.debian.net (or p.d.o or whatever)?

Probably this should be asked on d-release also. 
At least we have a couple of different classes of programa involved:

- antivirus, antispam and IDS. 
I think there is a larger consensus on this kind of programs to stay in volatile area.

- interactive workstation-use monsters (mozilla family, galeon (?) and what else)
for which security upgrades could be difficult, for example.
This class requires a case-by-case evaluation, surely: e.g. upgrading
to major version of a beast like galeon which is strongly
gnome-connected, could be impractical maybe.

What we probably need is the infrastructure to support the volatile
archive (buildd support and pools) and a general policy for those kind 
of updates. Program choices could be done later, as for point releases.
So I don't see any reason to remove clam at this stage, for instance.

Francesco P. Lovergine

Reply to: