[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#264710: ITP: libsem -- Portable, pthread-based semaphore library

Package: wnpp
Severity: wishlist

* Package name    : libsem
  Version         : 0.0.1
  Upstream Author : Gael Le Mignot <kilobug@freesurf.fr>
* URL             :
* License         : LGPL
  Description     : Portable, pthread-based semaphore library

This is a portable, pthread-based implementation of POSIX semaphores. It was
initialy written as a patch for the Hurd.  However, since it only relies on
portable interfaces like pthread, it can be used on any sane system.

I intend to enable this library for all dpkg architectures in which the
system doesn't currently provide semaphores (to avoid symbol conflicts).
This means the only official architecture this package will be compiled for
is hurd-i386.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: kfreebsd-i386 (i386)
Kernel: GNU/kFreeBSD 5.2.1-5
Locale: LANG=C, LC_CTYPE=C (ignored: LC_ALL set to C)

Reply to: