[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian/sarge: Gcc introduced invalid option "--as-needed"

On 2004-08-06 Otto Wyss <otto.wyss@orpatec.ch> wrote:
> Since about a week I can't compile with gcc since it invokes ld with
> illegal option "-as-needed" (see log).
> gcc version 3.3.4 (Debian 1:3.3.4-7)
> Please either revert gcc to a version before this change or upgrade ld
> to a compatible version in the current Debian/sarge.

Your subject says "Debian/sarge", but you are using gcc-3.3 from
unstable, version 1:3.3.4-7. Either downgrade to the version in sarge
or also install binutils from unstable, *or* use the gcc-3.3 in
See <http://bugs.debian.org/263426>.
                 cu andreas
"See, I told you they'd listen to Reason," [SPOILER] Svfurlr fnlf,
fuhggvat qbja gur juveyvat tha.
Neal Stephenson in "Snow Crash"

Reply to: