[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#263245: kionjb: Qt3 package links with libpng2

I'm using KDE3 from download.kde.org on my Debian Woody (with some
packages from testing) system. If I attempt to remove any of


apt tells me it has to remove all of the KDE packages. I don't see how
these packages can depend on four different libpng packages, so what's
going on here? How are these packages related? Which -dev package
should I be using to build packages?


On Tue August 3, 2004 06h59, Josselin Mouette wrote:
> Package: kionjb
> Version: 0.1.6-1
> Severity: serious
> kionjb is a Qt3 package. As such, it links indirectly with libpng3. But
> it also links directly with libpng2, without using a recent version with
> versioned symbols.
> kionjb must be rebuilt using libpng3, not libpng2.
> Regards,

Reply to: