[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: When does a conflict become outdated?

On Thu, Apr 01, 2004 at 08:01:00AM +0200, Marc Haber wrote:
> On Wed, 31 Mar 2004 16:16:02 +0200, Morten Brix Pedersen
> <morten@mbrix.dk> wrote:
> >Many old packages in Debian, have conflicts for specific version of
> >packages that are pre-potato. Would it then be OK to submit a minor bug
> >and tell the maintainer that the conflict could be removed?
> >
> >For example, the debconf package has Conflicts: menu (<= 2.1.3-1). But
> >even potato has menu 2.1.5-10.1, so the conflict is not of much use
> >anymore.
> I tend to keep these conflicts in to cater for the stupidity of our
> users. To give a reason: exim4's maintainer scripts create a user
> account. This account creation fails if the version of passwd is in a
> certain range due to a bug in passwd. The buggy versions are newer
> than woody, but older than testing, so any Debian system running a
> current version of any distribution is fine.
> However, there have been gazillions of bug reports against exim
> because people keep running outdated versions of unstable. We hat to
> add a versioned conflicts just to keep the number of bug reports down,
> while that conflict is technically not necessary any more. And no,
> that conflicts is bound to stay for a while. Won't be removed any time
> soon.

Conflicts for post-woody versions are definitely required for
Debian 3.1.

Due to stable being completely outdated, many people are in a
backport-hell, or they followed the message from some Debian developers
who told that stable + testing with apt pinning would solve their

> Greetings
> Marc



       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Reply to: