[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: When does a conflict become outdated?

On Wed, 31 Mar 2004 16:16:02 +0200, Morten Brix Pedersen
<morten@mbrix.dk> wrote:
>Many old packages in Debian, have conflicts for specific version of
>packages that are pre-potato. Would it then be OK to submit a minor bug
>and tell the maintainer that the conflict could be removed?
>For example, the debconf package has Conflicts: menu (<= 2.1.3-1). But
>even potato has menu 2.1.5-10.1, so the conflict is not of much use

I tend to keep these conflicts in to cater for the stupidity of our
users. To give a reason: exim4's maintainer scripts create a user
account. This account creation fails if the version of passwd is in a
certain range due to a bug in passwd. The buggy versions are newer
than woody, but older than testing, so any Debian system running a
current version of any distribution is fine.

However, there have been gazillions of bug reports against exim
because people keep running outdated versions of unstable. We hat to
add a versioned conflicts just to keep the number of bug reports down,
while that conflict is technically not necessary any more. And no,
that conflicts is bound to stay for a while. Won't be removed any time


-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber          |   " Questions are the         | Mailadresse im Header
Karlsruhe, Germany  |     Beginning of Wisdom "     | Fon: *49 721 966 32 15
Nordisch by Nature  | Lt. Worf, TNG "Rightful Heir" | Fax: *49 721 966 31 29

Reply to: