[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel Maintenance

When removing kernel-source packages from a released or to-be released
distribution, please *always* ensure that no package is left over that
build-depends on this.

For example, woody has:

kernel-image-2.4.19 for mips but no kernel-source-2.4.19

kernel-image-2.2.10 for powerpc/apus but no kernel-source-2.2.10

kernel-image-2.2.20 for i386 which build depends on modules-scyld-source-0.1
       which does not exist in woody

kernel-image-2.2.19-{netwinder,riscpc} for arm but no kernel-source-2.2.19

Please, please, pretty please make sure that no package depends or
build-depends on a kernel package you want to remove from a distribution.
Otherwise maintaining security updates IS PURE PAIN AND HORROR.
Currently it is so and it only gets worse.



Beware of bugs in the above code; I have only proved it correct,
not tried it.  -- Donald E. Knuth

Please always Cc to me when replying to me on the lists.

Reply to: