[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: python again (was: Bug#225999: ITP: debsync -- installed packages synchronization tool)

On Mon, Jan 05, 2004 at 10:51:53AM -0800, Will Lowe wrote:
> > version of Python.  If it requires feature specific to Python 2.3, it
> > could Depend on python (>= 2.3) and leave it at that.  This would
> But since we allow the user to have several versions on Python on the
> system at the same time, this means that a module that requires 2.3 is
> in a place where /usr/bin/python2.1's "import" function can find it.
> That seems like a problem if someone changes the /usr/bin/python link
> from python2.3 to python2.1 for example.

/usr/bin/python is provided as part of the python package.  It is not an
alternative.  If the python package is 2.3, it is expected that
/usr/bin/python is 2.3.  You may as well install vi over
/usr/bin/gcc-3.3 and the complain about breakage.

If the module depends on python (>= 2.3), then /usr/bin/python is
guaranteed to be 2.3 or above, and all scripts using that module can
safely use /usr/bin/python.

-- John

Reply to: