Re: python again (was: Bug#225999: ITP: debsync -- installed packages synchronization tool)
> version of Python. If it requires feature specific to Python 2.3, it
> could Depend on python (>= 2.3) and leave it at that. This would
But since we allow the user to have several versions on Python on the
system at the same time, this means that a module that requires 2.3 is
in a place where /usr/bin/python2.1's "import" function can find it.
That seems like a problem if someone changes the /usr/bin/python link
from python2.3 to python2.1 for example.
Does python have an equivalent of the Perl "use 5.6;" for allowing a
module to specify gracefully that it can't be used with an interpreter
older than version 5.6?