[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A new way to specify versionned dependencies may be needed



On Tue, Oct 07, 2003 at 11:00:23PM +0200, Nicolas Boullis wrote:
> People currently specify things as "Depends: foo (>= 1.0.0-1), foo (< 
> 1.0.1)". But that will break if more than one version of foo can coexist 
> at a time. That's currently impossible, but that may become possible 
> when versionned provides are available 

Right, but if so, we have to avoid that being a problem anyway (otherwise,
we'll break upgrades). One way of avoiding it would be to make packages like:

	Package: foo
	Provides: xyzzy (= 1.0)

	Package: bar
	Provides: xyzzy (= 2.1)

implicitly conflict; which makes that consideration a non-issue, but is
probably more restrictive than we'd like. Another way is to just have
a policy that says that versioned virtual packages provide an interface,
so you always Depend on an exact version, a la:

	Package: foo
	Depends: xyzzy (= 1)

	Package: bar
	Provides: xyzzy (= 1)

	Package: baz
	Provides: xyzzy (= 1), xyzzy (= 2)

Having something more complicated is certainly possible, but at the
moment there just don't seem to be any significant benefits to justify
worrying about it, let alone the fairly complicated changes it'd require.

Cheers,
aj

-- 
Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. GPG signed mail preferred.

Australian DMCA (the Digital Agenda Amendments) Under Review!
	-- http://azure.humbug.org.au/~aj/blog/copyright/digitalagenda

Attachment: pgpKiyHtbXFQH.pgp
Description: PGP signature


Reply to: