[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree86 4.3.0

On Tue, 16 Sep 2003 14:00:56 -0700 (PDT)
TongKe Xue <qckcode@yahoo.com> wrote:

> Hello,
>   I'm currently trying to get XFree86 4.3.0 to work on Debian stable.

If you're trying to get experimental packages to work on stable, then I
really got the feeling you're with the wrong suite. Sounds you're more a
testing/unstable somebody.

>   On another separate note, when I was downloading the various
> packages by hand to meet the dependencies of XFree86 4.3.0, I was
> wondering it there was any effort to "automate" the process,
> something along the lines of the user chooses "I have a system based
> on [stable/testing/unstable], I would like to download the following
> *.debs (of newer version)" and then the system generates the
> selection of all required *.deb to meet the previous dependencies,
> puts it in a tgz, and the user can download it (seems rather
> repetitive with apt already existing, but could be helpful for
> upgrading packages on machines w/o net access (installed from CD
> sets)) -- just an idea.

I think you want apt pinning (man apt_preferences). You can tell apt
what you're standard suite is [stable/testing], but still get packages
from unstable.

apt-get install -t unstable <pacakge>

grts Tim

Reply to: