[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ruby-defaults 1.8.0

Fumitoshi UKAI writes:
> Hi, ruby package maintainers!
> I've upload new ruby-defaults that make ruby 1.8.0 the debault version of ruby.
> I contains some new binary package so it takes time to get into unstable.
> You can get the new ruby-defaults from
>  deb http://pkg-ruby.alioth.debian.org/deb/ ./
>  deb-src http://pkg-ruby.alioth.debian.org/deb/ ./
> Note that 
>  - packages that depends on ruby (<< 1.7) will be removed by dist-upgrade.
>    It must be fixed to depend on ruby1.6, or to change dependency version
>    if it works with ruby 1.8.
>  - I don't recommend that package depends on libruby. Instead, ruby module
>    package should depend on libruby1.8 or libruby1.6.
>  - module packages that build-depends on ruby-dev MUST be fixed to
>    use ruby1.8-dev (or ruby1.6-dev) instead of ruby-dev.

I did a NMU for swig1.3 (depending on ruby). I'm wondering why make a
version the default, if it does not build on all archs (powerpc). How
are package maintainers supposed to handle this? what will the
ruby-defaults package default to on the powerpc architecture?

Thanks, Matthias

Reply to: