[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: why no python, tcl, tk metapackage?

[ I have certainly been trolled, but you piss me off far too much: ]

On Wed, Jul 23, 2003 at 09:03:26AM +0800, Dan Jacobson wrote:
> I see my sid system has collected various python 2.1 and 2.2 packages, but
> no 2.3 packages.  Couldn't there be a python metapackage that I could
> install to always keep python at its freshest, also saving disk space
> by disposing older versions?

There is a python metapackage:
Package: python
Priority: standard
Section: python
Installed-Size: 408
Maintainer: Matthias Klose <doko@debian.org>
Architecture: all
Version: 2.2.3-3
Depends: python2.2 (>= 2.2.3-2.1)

However, python2.3 is not the default yet. If you need profusely
bleeding edge stuff all the time, please don't use Debian, or do the
work yourself and keep an eye on experimental. Debian is about being
moderately stable at all times.

Of course, when python becomes Version: 2.3.x-x, it will hold itself
back when you apt-get upgrade, because it's too nice to remove itself
and the 99999999999 other things that depend on it. Perhaps you are
experiencing this?

> In particular, after purging 2.1 et. al. by hand, I have all these:
> $ COLUMNS=888 dpkg -l|awk '/python2.2/{print $2}'|xargs
> idle-python2.2 python2.2 python2.2-dev python2.2-doc
> python2.2-egenix-mxdatetime python2.2-egenix-mxtools
> python2.2-examples python2.2-extclass python2.2-gadfly python2.2-gdbm
> python2.2-imaging python2.2-imaging-sane python2.2-imaging-tk
> python2.2-ldap python2.2-mpz python2.2-numeric python2.2-optik
> python2.2-tk python2.2-xml python2.2-xmlbase

It is fairly obvious that if you purge 2.1, 2.2 packages will not be

And removing, say, 2.2, will remove the whole shebang of 2.2 packages,

$ sudo apt-get remove python2.2
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  bittorrent dia-common dia-gnome gnumeric libbonoboui2-dev libglade2-dev
  libgnomeui-dev libpanel-applet2-dev linda python python-dev python-gtk
  python-gtk2 python-newt python-optik python-xmlbase python2.2 python2.2-dev
  python2.2-gtk2 python2.2-optik python2.2-xmlbase reportbug xchat
0 packages upgraded, 0 newly installed, 23 to remove and 0 not upgraded.
Need to get 0B of archives.

So, that is an issue of your sheer incompetence.

> I suppose I can only pipe this list to sed 's/2.2/2.3/g'|xargs apt-get install,
> there being no better way to upgrade them?

You'd need a --yes there, and it's no use anyway:

$ dpkg --get-selections | grep python2.2 | awk '{print $1}' | sed 's/2.2/2.3/' | xargs sudo apt-get --yes install
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package python2.3-optik

Because as you might have discovered with a little bit of searching that
not all python2.2 stuff necessarily works with 2.3.

> Wait, tcl seems to be in the same state, both 8.3 and 8.4 installed,
> whats worse, many packages e.g. depend on tcl8.3 (>= 8.3.0), and not
> tcl (>= 8.3.0).  But a developer couldn't specify the latter because the
> version number is hardwired into the only available package's name.

The reason for this is that stuff may have regressed in future versions
that we don't yet know about, so let's not jeopardize other programs
depending on a dumb tcl >= XXXversion package when tcl9.7 breaks or
discontinues support for older tcl stuff.

There's a reason why Debian does everything, and you have been sorely in
the wrong in every discussion you have started.

I'd say that you are close to becoming Debian's Rick Hohensee


Using words to describe magic is like using a screwdriver to cut roast beef.
		-- Tom Robbins

Attachment: pgpNJTNj1Xski.pgp
Description: PGP signature

Reply to: