[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

APT- Get Error - Dynamic MMap ran out of room

Hi all,

As a brand newbie to linux,  I'm hoping that someone can help me out with a problem.

I recently installed Debian and ran apt-get update but keep getting the same error messages.  I've been attached to google for the last few days and tried everything I could find but no success.

The message is as follows;

Reading Package Lists...Error!
E: Dynamic MMap ran out of room
E: Dynamic MMap ran out of room
E: Error occured while processing shoop-dev (NewVersion1)
E: Problem with MergeList /var/state/apt/lists/wuarchive.wustl.edu_mirrors_debian_dists_stable_main_binary-i386_packages
E: msync
E: The package lists or status file could not be parsed or opened.

I created an apt.conf file in /etc/apt and added;

APT::Default-Release "stable";
APT::Cache-Limit "141943904";

I experimented with different cache limits and eventually decided to go for overkill but changing the cache size in /etc/apt/apt.config  did not help and the problem persists, I cannot use apt at all! 

I have also changed my source file and also reduced it to only one entry and have tried using different mirrors.  I am able to connect quite okay and it downloads 1777kb but when apt is reading the list it gets to 66% and up comes the error every time.

# deb ftp://ftp.au.debian.org/debian stable main contrib non-free
deb http://
wuarchive.wustl.edu/mirrors/debian stable main contrib non-free

I'm sure this has nothing to do with lack of memory or space, there is enough of both. I've google'd on this for days and can see that i'm not the only one who suffers this problem but non of the suggestions that seem to work for others is doing anything for me.

Urghh this is so frustrating.

Cheers and thanks for any help.

Mike Haill

Reply to: