[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Stefano =)] Bug#198619: Could not perform configuration on libpam0g

> > Hello,
> >
> > In fact, i have also this bug. It comes from a circular versionned
> > dependency betwee lipam0g and libpam-modules :
> >
> > libpam0g depend on libpam-modules > 0.7.X and
> > libpam-modules depends on libpam0g > 0.7.X...
> >
> > So if you try to upgrade from a version below 0.7.X you cannot get it to
> > work... Or you have to ignore the dependcy...
> this is a bug in apt.  dpkg correctly handles this case(it breaks the dep loop
> randomly, which means postinsts of the affected packages need to be aware of
> the issue.
> The apt developer has refused to fix apt to work around this non-problem in
> the past, I suggest you take it up with him.


Thanks for the invitation for working on apt ;->

But i was just saying that i try to understand the problem and find the
solution. After all, i had to dig a bit but i find a solution... 

I really don't want to argue on the need of working on apt or not. It is
just a bug report ( but i don't know if i need to fill a bug against pam
or pat now ). 

Kind regard
Sylvain LE GALL

Reply to: