[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get error

On woody, I get the following error. It worked yesterday...

Any ideas?

# apt-get update
Hit http://snoopy.apana.org.au unstable/main Packages
Hit http://snoopy.apana.org.au unstable/main Release
Hit http://snoopy.apana.org.au unstable/selinux Packages
Hit http://snoopy.apana.org.au unstable/selinux Release
Fetched 183kB in 60s (3039B/s)         
Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing mozilla-browser (NewFileVer1)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

/var/lib/status looks OK to me, including the mozilla-browser entry.
ls shows:

-rw-r--r--    1 root     root      1486196 Jun  9 18:35 /var/lib/dpkg/status

status contains information on a lot of packages I *know* I have never
installed before (listed as purged), I tried "dpkg --forget-old-unavail"
but this didn't remove them.

Also memory is hardly short in supply:

scrooge:~# free
             total       used       free     shared    buffers     cached
Mem:        256832     234508      22324          0      46880      91332
-/+ buffers/cache:      96296     160536
Swap:       491360     159148     332212

So how do I make apt-get start working again?
Brian May <bam@debian.org>

Reply to: