[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libnspr and libraries in /usr/lib that require it



On Fri Apr 04, 03:04am +0200, Simon Richter wrote:
> Marek,
> 
> > > So the "official" libnspr (the one in the stable releases) could go into
> > > /usr/lib/, and things built against Mozilla would run normally, and the
> > > one in mozilla-snapshot would go into /usr/lib/mozilla-snapshot/, where
> > > it would also be picked up by things compiled against -snapshot.
> 
> > That idea crossed my mind, but it would mean duplication of the libnspr
> > package. What about symlinking libnspr.so from /usr/lib/mozilla to /usr/lib,
> > however?
> 
> No, that would make the release and the snapshot conflict. Just compile
> your package against release, snapshot or both and put the library in
> the same dir as libnspr.

I don't see how. LD_LIBRARY_PATH is (necessarily) set for apps which use
-snapshot libs. So they'll get those libs before the ones in /usr/lib
are even considered.

Attachment: pgpx77LcIdKei.pgp
Description: PGP signature


Reply to: