[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: versioned depends not working

On Mon, Jan 06, 2003 at 10:26:35AM +1100, Brian May wrote:

> On Sun, Jan 05, 2003 at 06:22:10PM -0500, Matt Zimmerman wrote:
> > Perhaps it has something to do with the fact that libnet-perl is a mixed
> > virtual package, provided by perl-modules.
> Not as far as I can tell:
> ns# dpkg -s libnet-perl
> Package: libnet-perl
> Status: install ok installed

A "mixed virtual package" exists both as a real package, and as a name
provided by other packages.

mizar:[~] apt-cache show perl-modules | grep '^Provides:.*libnet-perl'
Provides: libpod-parser-perl, libansicolor-perl, libfile-temp-perl, libnet-perl, libstorable-perl, libattribute-handlers-perl, libcgi-pm-perl, libi18n-langtags-perl, liblocale-maketext-perl, libmath-bigint-perl, libnet-ping-perl, libtest-harness-perl, libtest-simple-perl

But as you noticed, this is not the problem.

> However, I now notice a small detail I missed before.
> That is the '1:' epoch.
> Maybe this is my problem? I probably should say (>= 1:1.12).

That should work fine; the actual version number of the current package is

 - mdz

Reply to: