[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Backporting the "dh_shlibdeps -L" option.



Hey everyone,
	Could someone please tell me how I should calling dh_shlibdeps
to avoid compatibility problems like those listed below? I am
currently using them as demonstrated by the example in the
dh_shlibdeps manpage:

dh_makeshlibs
dh_shlibdeps -L libgcm0 -l debian/libgcm0/usr/lib

Thanks in advanced,
Andrew "Netsnipe" Lau

----- Forwarded message from Silvestre Zabala <silvestre.zabala@gmx.net> -----

From: Silvestre Zabala <silvestre.zabala@gmx.net>
To: Andrew Lau <netsnipe@debianplanet.org>
Subject: FTBFS: gcm
X-Apparently-From: KunischBernhard@aol.com
X-Spam-Status: No, hits=0.5 required=5.0
	tests=RCVD_IN_OSIRUSOFT_COM,SIGNATURE_SHORT_DENSE,
	      SPAM_PHRASE_03_05,USER_AGENT,USER_AGENT_MUTT,X_OSIRU_DUL,
	      X_OSIRU_DUL_FH
	version=2.43
X-Spam-Level: 

Hello, 

I've seen your deb line for gcm on gtk-gnome@l.d.o and tried to download and 
build gcm. I'm using a woody system with the kov's GNOME 2 backport.
However, the build problems I've experienced are not related to that:

[...]
dh_shlibdeps -L libgcm0 -l debian/libgcm0/usr/lib
Unknown option: L
dh_shlibdeps: unknown option; aborting

So it seems that gcm depends on a higher version of debhelper than I
have installed (4.0.2) and not only Build-Depends: debhelper (>> 3.0.0).

Thank you for your work,
  Silvestre

-- 
http://www.rzuser.uni-heidelberg.de/~szabala/

----- End forwarded message -----

-- 
---------------------------------------------------------------------------
* Andrew "Netsnipe" Lau              Computer Science & Student Rep, UNSW *
*   # apt-get into it                 Debian GNU/Linux Package Maintainer *
*     <netsnipe(+)debianplanet.org\0>      <alau(+)cse.unsw.edu.au\0>     *
* GnuPG 1024D/2E8B68BD 0B77 73D0 4F3B F286 63F1  9F4A 9B24 C07D 2E8B 68BD *
---------------------------------------------------------------------------

Attachment: pgpxeMtWK_hZj.pgp
Description: PGP signature


Reply to: