[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Lintian



On Mon, Oct 14, 2002 at 05:33:32PM +0200, Josip Rodin wrote:
> On Mon, Oct 14, 2002 at 02:43:31PM +0200, Aaron Isotton wrote:
> > whenever I check a package with lintian I get the following output:
> > 
> > aisotton@zarathustra:~/debian/gif2png$ lintian gif2png_2.4.6-1_i386.changes 
> > internal error: error occured during execution of dpkg-source: 
> > internal error: could not unpack package to desired level: No such file or directory
> > N: Skipping check of source package gif2png
> 
> 
> It seems Perl 5.8 doesn't like something in Lintian. And it's a heisenbug as
> well, I can't reproduce it :(
> 

Some of the perl bugs only seem to appear in UTF-8 locales (e.g.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=158624&repeatmerged=yes)

I get the same error from lintian (only when I run it on a changes file, not
a deb file), and I use a UTF-8 locale.  But it happens in my case apparently
because it doesn't find enough room in /tmp.  Lintian runs fine on one of my
smaller packages, but breaks on a larger package (xprint-xprintorg, src 18MB,
/tmp has 85MB free).

I'm still on version 1.21 though, haven't upgraded to 1.21.1 yet.

Drew

-- 
PGP public key available at http://people.debian.org/~dparsons/drewskey.txt
Fingerprint: A110 EAE1 D7D2 8076 5FE0  EC0A B6CE 7041 6412 4E4A

Attachment: pgpxW9J9hadpJ.pgp
Description: PGP signature


Reply to: