[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#159037: general: Time Problem

A friend of mine told me about a known bug that has a fix in the up 
comming 2.4.20 kernel (currently at pre5), the option is 
CONFIG_X86_TSC_DISABLE, attached is the information about it.  It 
appears to have solved the problem for me.  From what I understand about 
this, the problem is in glibc, although it is odd that I did not suffer 
from this prior to my rebuild.

---Kernel Info---

This option is used for getting Linux to run on a NUMA multi-node
boxes, laptops and other systems suffering from unsynced TSCs or
TSC drift, which can cause gettimeofday to return non-monotonic values.
Choosing this option will disable the CONFIG_X86_TSC optimization,
and allows you to then specify "notsc" as a boot option regardless of 
which processor you have compiled for.

NOTE: If your system hangs when init should run, you are probably
using a i686 compiled glibc which reads the TSC wihout checking for
avaliability. Boot without "notsc" and install a i386 compiled glibc
to solve the problem.

I hope this solves the problem for you as well.

On Sat, Aug 31, 2002 at 11:07:54PM -0700, Daniel Schepler wrote:
> "Matt Filizzi" <fizz@beyond.hjsoft.com> writes:
> > Package: general
> > Version: N/A; reported 2002-08-31
> > Severity: normal
> > Tags: sid
> > 
> > I don't know what is causing this problem but all I know is that I have
> > narrowed it down to being caused either by a package or by the install
> > system.  I installed from the woody install disks then upgraded to sid.
> > What happenes is that the time jumps ahead then back, eg (this is output
> > from "while true; do date;done"
> > 
> > Sat Aug 31 19:07:26 EDT 2002
> > Sat Aug 31 19:07:26 EDT 2002
> > Sat Aug 31 19:07:26 EDT 2002
> > Sat Aug 31 19:07:26 EDT 2002
> > Sat Aug 31 20:19:01 EDT 2002
> > Sat Aug 31 20:19:01 EDT 2002
> > Sat Aug 31 20:19:01 EDT 2002
> > Sat Aug 31 19:07:27 EDT 2002
> > Sat Aug 31 19:07:27 EDT 2002
> > 
> > The only thing I did differently then previous installs was I told the
> > installer that it could set the bios go UTC.  The only time it is really
> > noticable is when in X, the screensaver kicks in when it jumps.
> I can confirm that this bug happens on my system as well, even as far
> as the time jump being approximately 71 minutes.  I had ntpd
> installed.  I've recently tried disabling ntpd, but since it happens
> very sporadically for me, I can't tell yet whether disabling that
> works -- it sometimes takes on the order of several weeks of uptime
> before it happens.
> My bios clock is also set to UTC.  I didn't even think of that as a
> possible cause before, but I don't see how this could be the cause
> since, as far as I know, the bios clock is only read or set at boot
> time or shutdown.
> -- 
> Daniel Schepler              "Please don't disillusion me.  I
> schepler@math.berkeley.edu    haven't had breakfast yet."
>                                  -- Orson Scott Card

Matt (Fizz) Filizzi                         All that is required for
http://beyond.hjsoft.com                    Evil to triumph is that
fizz@beyond.hjsoft.com                      good people do nothing.
                                              - Edmund Burke

Reply to: