[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#154680: libsdl-mixer1.2 doesnt work with latest vorbis (1.0.0)

On Mon, Jul 29, 2002 at 09:32:59AM -0500, Steve Langasek wrote:
> On Mon, Jul 29, 2002 at 08:33:38AM -0500, Christian T. Steigies wrote:
> > This and:
> >  Bug#154704: defenguin 0.0.10-1 needs to depend on libvorbisfile3
> > sounds to me like the libpng mess I already created with sdl-image.
> > So sdl-mixer has also been broken by a new library now? I haven't done any
> > upload of sdl-mixer yet, this time I'd like to do it right. I assume when I
> > upgrade sdl-mixer to use vorbis1.0, old packages using sdl-mixer might brake
> > just as they brake with sdl-image and png2/3?
> Only if other packages which depend on sdl-mixer are directly linked
> against libvorbis as well.  If they are, this is almost certainly a bug
> in those packages.

As far as I can see defendguin does not depend nor link with libvorbis*, but

ldd /usr/games/defendguin | grep vorb
        libvorbisfile.so.0 => /usr/lib/libvorbisfile.so.0 (0x404d6000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x404dd000)

I think the problem is libvorbisfile3:

 Version: 1.0.0-1
 Conflicts: libvorbis0 (<< 1.0.0)
 Replaces: libvorbis0 (<< 1.0.0)
-rw-r--r-- root/root     22532 2002-07-19 10:45:51 ./usr/lib/libvorbisfile.so.3.0.0
lrwxrwxrwx root/root         0 2002-07-19 10:45:51 ./usr/lib/libvorbisfile.so.3 -> libvorbisfile.so.3.0.0


To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: