[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#140635: ftp-ssl should "Provides: ftp-client"

On Mon, Jul 15, 2002 at 02:52:57PM +0200, Christoph Martin wrote:
> Am Mon, 2002-07-15 um 12.45 schrieb Ben Finney:
> > Package: ftp-ssl
> > Version: 0.17.9+0.2-2
> > Severity: normal
> [...]
> > However, as at version 0.17.9+0.2-2 (possibly earlier), the
> > debian/control entry for ftp-ssl does not "Provides: ftp-client".
> ftp-ssl simply does the same as ftp. And if I Remember correctly,
> ftp-client is not a virtual package and the Provides was therefore
> removed.

This seems to be completely opposed to prior comments on this same bug
(#140635).  What are you suggesting should be the resolution?  Should
ftp-ssl "Provides: ftp", or should both ftp and ftp-ssl "Provides:

This is important for packages that "Depends: ftp" currently.  Should
they continue to do so, or should they "Depends: ftp-client" instead?
Or something else?  Currently, installing ftp-ssl does not satisfy
packages that "Depends: ftp", and it seems this new version of ftp-ssl
does not move closer to resolving that situation.

 \        "I washed a sock. Then I put it in the dryer. When I took it |
  `\                              out, it was gone."  -- Steven Wright |
_o__)                                                                  |
bignose@zip.com.au  F'print 9CFE12B0 791A4267 887F520C B7AC2E51 BD41714B

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: