[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unparsable gcc version string? [WAS: lily 1.4.15]

Peter Chubb <peter@chubb.wattle.id.au> writes:

> This is in the stepmake part.
> Looks a bit weird.

Thanks.  Actually, it looks fine, but

> : wombat ; gcc --version
> gcc (GCC) 3.1.1 20020606 (Debian prerelease)

AAARG!  How is anyone (being a humble configure script) supposed to
pick `3.1.1<SPACE>20020606' to be the version string from that?  I
could live with something like

    gcc (GNU CC) 3.1.1-20020606-debian-prerelease

or even

    gcc (GNU CC) 3.1.1-20020606 (Debian prerelease)

I think maybe someone should file a bug to the Debian gcc package.
LilyPond will not be the only package to verify the version of the


xs3 $ gcc --version
peder $ gcc --version
$ bison --version
bison (GNU Bison) 1.35
$ flex --version
flex version 2.5.4
$ guile --version
Guile 1.5.6

Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: