[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Proposal for fixing automake (was Re: State of automake packages)

* Anthony Towns (aj@azure.humbug.org.au) wrote:
> On Fri, Jun 07, 2002 at 03:17:48PM -0400, Eric Dorland wrote:
> > > If feasible, my preference would be that the package "automake"
> > > contains the latest version (i.e. 1.6).  The older version could be
> > > stuck in "automake1.4", if need be.  [I wonder whether 1.5 is even
> > > needed at this point.]
> > > The reason that it is the other way around was mainly to avoid lots of
> > > breakage during the woody freeze.  Since woody is now frozen, we ought
> > > to be able to reverse the practice now.
> > That's a nice idea, but it means that things that depend on "automake"
> > could break the next time a new version of automake is released. 
> Right, which means things shouldn't depend on "automake". Unfortunately we
> weren't expecting upstream to randomly break compatability like that, so
> whole swathes of packages _did_ depend on automake. Making "automake.deb"
> be automake1.4 worked around this for us since the buildds will always
> choose a real package named "automake" in place of the virtual package
> provided by automake1.5. You'll probably want to be careful not to break
> this for a while, which means not having "automake.deb" be version 1.5
> or 1.6.

Yes, I totally agree.

> One possibility is to make "automake1.4.deb" be the only package that
> provides "automake", and then adjust the conflicts between automake
> 1.4 and automake 1.5 to ensure they don't get installed together if it
> breaks things. If we've got three versions of automake, which aren't
> particularly compatible, and which are all used widely, there's probably
> not that much value in trying to provide a "canonical" automake.deb.

Yes, but that seems like a bit of an inelegant solution, since it is
possible for a package to want any automake, not necessarily
automake1.4. It is possible to write Makefile.am's that are portable
across all the current versions. It would be nice if packages which
depend on automake could depend on the right version (eg. automake1.4
or automake1.5) if it really does depend on a specific version.
> There's probably no need for a dummy package -- they're only really
> useful when you're splitting a package.

Yes, but it might be nice for someone to do apt-get install automake
and get a nice version of automake installed. I realize that's
somewhat low priority, but it would still be nice :)

> Cheers,
> aj

Eric Dorland <dorland@lords.com>
ICQ: #61138586, Jabber: hooty@jabber.com
1024D/16D970C6 097C 4861 9934 27A0 8E1C  2B0A 61E9 8ECF 16D9 70C6

Version: 3.12
GCS d- s++: a-- C+++ UL+++ P++ L++ E++ W++ N+ o K- w+ 
O? M++ V-- PS+ PE Y+ PGP++ t++ 5++ X+ R tv++ b+++ DI+ D+ 
G e h! r- y+ 

Attachment: pgpcP7kYdfkAc.pgp
Description: PGP signature

Reply to: