[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sid: libc6-2.2.5-4 kills vmware workstation 3.0

On Tue, 26 Mar 2002 19:59, Stephen Frost wrote:
> * Mike Phillips (phillim2@comcast.net) wrote:
> > On Tue, Mar 26, 2002 at 06:55:50PM +0100 or sometime in the same epoch, 
Marek Habersack scribbled:
> > > Exactly... But it looks like a broken IPC handle or something... Also,
> > > did you notice that vmware ignores (how?) the LD_LIBRARY_PATH variable?
> >
> > Yep, saw that. vmware does some very clever and very bizarre things at
> > times. I have played with the vmnet source before when 2.0 wasn't
> > working with some of the 2.4.x kernels and they certainly rely on too
> > many things being in a certain place.
> Check the permissions on vmware.
> -r-sr-xr-x    1 root     staff     2110200 Nov 23 09:58
> /usr/local/bin/vmware
> Try to use LD_LIBRARY_PATH on /bin/su.  You'll notice there's a
> coincidence. :)

So if you login as root and change the permissions on the file to 755 and run 
it as root the LD_LIBRARY_PATH and LD_PRELOAD should work.

If you send email to me or to a mailing list that I use which has >4 lines
of legalistic junk at the end then you are specifically authorizing me to do
whatever I wish with the message and all other messages from your domain, by
posting the message you agree that your long legalistic sig is void.

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: