[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with perl potato -> woody

Hi all,

Taking machine up from potato to woody, this is what happened:

(Stock up-to-date potato to woody, apt-get dist-upgrade)

--- snip ---

Preparing to replace libstdc++2.10-dev 1:2.95.2-13 (using
.../libstdc++2.10-dev_2.95.4-1_i386.deb) ...
perl: /lib/libc.so.6: version `GLIBC_2.2' not found (required by
dpkg: warning - old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
perl: /lib/libc.so.6: version `GLIBC_2.2' not found (required by
dpkg: error processing
/mirrors/linux/debian/pool/main/g/gcc-2.95/libstdc++2.10-dev_2.95.4-1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
dpkg: regarding .../libc6-dev_2.2.5-3_i386.deb containing libc6-dev:
 libc6-dev conflicts with libstdc++2.10-dev (<< 1:2.95.2-15)
  libstdc++2.10-dev (version 1:2.95.2-13) is installed.
dpkg: error processing
 conflicting packages - not installing libc6-dev
Selecting previously deselected package libgtk1.2-common.
Unpacking libgtk1.2-common (from .../libgtk1.2-common_1.2.10-9_all.deb)
Replacing files in old package libgtk1.2 ...
Preparing to replace xfree86-common 3.3.6-11potato32 (using
.../xfree86-common_4.1.0-14_all.deb) ...
Note: Removing obsolete symbolic link /usr/X11R6/lib/X11/doc.
Unpacking replacement xfree86-common ...
Selecting previously deselected package libfreetype6.
Unpacking libfreetype6 (from .../libfreetype6_2.0.9-1_i386.deb) ...
Errors were encountered while processing:

E: Sub-process /usr/bin/dpkg returned an error code (1)

--- snip ---

perl now doesn't run, with the error
phlegethon:/mirrors/linux/debian/dists# perl
perl: /lib/libc.so.6: version `GLIBC_2.2' not found (required by

I have seen this several times doing these upgrades. How can I help
track it down? Has anyone else seen this problem?

Grahame Bowland                       Email: grahame@ucs.uwa.edu.au
University Communications Services    Phone: +61 8 9380 1175
The University of Western Australia     Fax: +61 8 9380 1109
                                     CRICOS: 00126G

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: