[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fun with libgal



>>>>> In article <Pine.NEB.4.44.0201241537330.14017-100000@mimas.fachschaften.tu-muenchen.de>,
>>>>> "AB" == Adrian Bunk <bunk@fs.tum.de> wrote...:
[...]

AB> >
AB> > As long as libgalxx-dev exists, and
AB> > libgtkhtml-dev has a Depends: on libgalxx-dev,
AB> > and libgalxx-dev Provides: Conflicts: libgal-dev,
AB> > it should be impossible to build an evolution
AB> > with libgalyy-dev.
AB> >...

AB> But it's possible to build a future version of libgtkhtml20 that depends
AB> on libgal20, IOW:

AB> Package: evolution
AB> Version: 1.0.1-1
AB> Depends: libgal19, libgtkhtml20

Then, evolution 1.0.1-1 has Serious Bug. need rebuild.
(uninstallable into sid system)

AB> Package: libgtkhtml20
AB> Version: 1.0.0-7
AB> Depends: libgal20

Yes. evolution should be rebuild with latest libgal.
And bump up Build-Depends libgal-dev (>= 0.20).

Depending on oldlibs is a Serious Bug and should rebuild, I think.

-- 
Takuo KITAME.



Reply to: