[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Depends frustration

> > I am trying to install libxercesicu1. It has Version: 1.5.2-2 and
> Provides:
> > libxerces1. Now, when I select that, dselect removes xalan which
> > libxerces1 (>= 1.5.1-1). Grrr...
> When a package depends on a particular version of another package,
> provides
> from other packages are not considered.

Hmmm. For libraries it is a big pain. I remember having issues with libpng2
too, who was basically deselecting all of KDE when chosen. How hard would
that be to change in dpkg so that provides: with matching versions could
work too?


Reply to: