[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#127747: general: libpng error: Incompatible libpng version in application and library


We're going to have a whole new round of complaints and such if
the broken packages get into testing.  

It seems to me that we should have high-severity open bugs on these
packages to prevent them from getting into testing before it is sorted

Do the new maintainers of libqt and KDE packages have a thick
enough skin to allow this?


On Fri, Jan 04, 2002 at 11:07:25AM +0100, Olivier Demah wrote:
> -- System Information
> Debian Release: 3.0
> Architecture: i386
> Kernel: Linux idefix 2.4.14-586-ext3 #1 Son Nov 11 22:48:53 CET 2001 i686
> Locale: LANG=fr_FR, LC_CTYPE=fr_FR
> Bcc: Olivier Demah <odemah@idefix.user.ipercast.net>
> Package: general
> Version: N/A; reported 2002-01-04
> Severity: grave
> Justification: renders package unusable
> When i launch quanta or opera for example thoses messages appear :
> libpng warning: Application was compiled with png.h from libpng-1.2.1
> libpng warning: Application  is running with png.c from libpng-1.0.12
> libpng error: Incompatible libpng version in application and library
> package installed :
> dpkg --list |grep png
> rc  libpng0g       0.96-5         PNG library - runtime
> ii  libpng2        1.0.12-3       PNG library - runtime
> ii  libpng3        1.2.1-1        PNG library - runtime
> if i try to uninstall lipng2 ; all KDE program would be uninstalled too
> same thing with libpng3.
> What can i do ?
> Regards.
> Olivier.
> -- 
> To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

by Rocket to the Moon,
by Airplane to the Rocket,
by Taxi to the Airport,
by Frontdoor to the Taxi,
by throwing back the blanket and laying down the legs ...
- They Might Be Giants

Reply to: