[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: update_excuses zope (also related to Bug #122443)

On Thu, Dec 06, 2001 at 05:56:55PM +0100, Tille, Andreas wrote:
> Hello,
>     http://ftp-master.debian.org/testing/update_excuses.html
> says:
> * zope (2.3.3-1 to 2.4.2-0.2)
>     * Maintainer: Gregor Hoffleit
>     * 36 days old (needed 10 days)
>     * Valid candidate

Well, I haven't looked at this one in particular, but:

If a package is a 'Valid Candidate' but is not installed by the
testing scripts,  that means that installing it would break things.

To find out what things, you do this:

List all packages generated by the *old* zope source package, 2.3.3.

Check for all packages in testing which currently depend on any of
those binary packages.

The scripts will not install zope 2.4.2 until it can do so without
breaking the Depends: of packages already in testing.  Typically that
means that any packages which depend on some 2.3.3-only component must 
be recompiled against zope 2.4.2 and also wait in unstable, when they
will all be installed together if they are all simultaneously valid

Again, I haven't looked at zope, but this is the usual situation.  It
explains why, for example, libtool 1.4.2 is not yet in testing.


Reply to: