[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#122642: ITP: ggz -- gaming network system


[cc'd to debian-devel because there seems to be a growing interest in our 
packages and some unnecessary parallel development...]

On Thursday 06 December 2001 02:28, Gustavo Noronha Silva wrote:
> Package: wnpp
> Version: N/A; reported 2001-12-05
> Severity: wishlist
> * Package name    : ggz
>   Version         : 0.0.4

For 0.0.4, please use the already available packages. You can get them from 
the SourceForge download page, or from http://zone.berlios.de.
They're done for potato and will need not only porting but also some 
additional bug fixes.

One BIG warning though: The reason why I never ITPd these is that waiting for 
0.0.5 to come out has several advantages, as we had for unknown reasons no 
upward compatibility in mind, which is fixed now.

The correct naming of the packages would be (except libeasysock which got an 
ITP on its own):

ggz-utils_0.0.4 (this is a convenience package only)

There is no general 'ggz' package, but I could imagine a task-ggz (or 
similar, named "GGZ Gaming Zone client packages") for our packages and the 
compatible ones like the T.E.G. or Bathalla 
Naval game (gbnclient), which are already packaged.

As Gustavo has contacted our development mailing list as well, we'll decide 
there whether it makes sense to carry around the 0.0.4 packages for some 
weeks, or if waiting that amount of time and starting with the improved, 
with-upward-compatibility-in-mind created 0.0.5 packages from scratch, 
avoiding possible potato workarounds as well.


The MindX Open Source Project: Fighting proprietary games
GGZ now! - The GGZ Gaming Zone: http://ggz.sourceforge.net
ggz.morat.net | ggz.snafu.de | jzaun.com | mindx.sourceforge.net/europeone

Reply to: