[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: atari800, svgalib, and non-i386 architectures

On Mon, Dec 03, 2001 at 05:19:53PM -0500, Dale Scheetz wrote:
> I just got a bug report on the atari800 package. It doesn't build on the
> powerpc because of missing svgalib components.
> The depends line is constructed by shlibdeps, and, while it includes the
> svgalibg1-dev, there is a [i386] associated with it that suggests that
> this dependency is only needed for i386. (at least that's the way the
> autobuilder interprets it) This clearly doesn't work correctly.
> So, my question is two-fold:
> 1. What arch's support svga?
> 2. How best to restrict the build to those ports?
> If the answer to 1. is "only i386", then the question becomes:

Check the svgalib source debian/control file, to see what it builds for.
Other architectures do have svgalib-dummy, and some have svgalib-ggi
(which allows it to use svga programs under ggi targets like X and

Check some other packages that use svgalib and see how they do it, also.

/                   Ben Collins    --    Debian GNU/Linux                  \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

Reply to: