[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trimming build dependencies

On Sat, Dec 01, 2001 at 01:02:59PM +0000, Colin Watson wrote:
> Hi,
> I noticed this in incoming:
>  licq (1.0.3-5.1) unstable; urgency=low
>  .
>    * NMU with permission
>    * Build with -O0 and -mieee for Alpha (Closes: #121678)
>    * Remove unneccesary build-depends as they are already depended upon
>      by packages which we build-depend on...ie kdelibs-dev depends on
>      libqt-dev which depends on libz-dev and libpng2-dev...so don't depend
>      on libqt-dev, libz-dev, or libpng2-dev since we indirectly do already.
> If the package does use any of these packages directly, then I think it
> should continue to build-depend on them directly. I agree that licq
> doesn't seem to use libz-dev or libpng2-dev itself, but it does use
> libqt-dev for more than licq-plugin-kde. I think policy 2.4.2 implies
> that that build-dependency should be restored.




     Julian Gilbey, Dept of Maths,             Debian GNU/Linux Developer
      Queen Mary, Univ. of London         see http://people.debian.org/~jdg/
   http://www.maths.qmul.ac.uk/~jdg/           or http://www.debian.org/
        Visit http://www.thehungersite.com/ to help feed the hungry
                 Also: http://www.helpthehungry.org/

Reply to: