[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Default MTA and dependencies

On Sat, 3 Nov 2001, Bdale Garbee wrote:

> noel@koethe.net (Noel Koethe) writes:
> > lintian produces a warning when you just use a virtual-package:
> Personally, I think lintian shouldn't consider this something it needs to
> warn about, and any tool that cares and doesn't provide some mechanism to
> handle this case is broken.
> That's sufficient and correct.  Depending on just a virtual package should be
> fine as along as at least one real package providing that virtual package is
> available.

It's a lintian warning but not a lintian error. I do think that lintian is
right to give a warning because it's in some cases (apt) easier for a user
if you give a default (e.g. "postfix | m-t-a"). This doesn't harm anyone
who has another MTA installed but it helps people who want to install the

> Bdale



Get my GPG key: finger bunk@debian.org | gpg --import

Fingerprint: B29C E71E FE19 6755 5C8A  84D4 99FC EA98 4F12 B400

Reply to: