[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with modutils under woody

On Tue, Oct 23, 2001 at 04:23:49PM -0400, Adam VanderHook wrote:
> On Tue, Oct 23, 2001 at 11:21:41AM -0600, Mark Paulus wrote:
> [...]
> > Error I'm getting is:
> > depmod: Unexpected value (20) in '/lib/modules/2.4.9-686-smp/kernel/drivers/ieee
> > 1394/sbp2.o' for ieee1394_device_size
> >         It is likely that the kernel structure has changed, if so then
> >         you probably need a new version of modutils to handle this kernel.
> >         Check linux/Documentation/Changes.
> > 
> > I'm attempting to remotely administrate this box, and I'm a little leery of 
> > rebooting this box at this time, as I'm worried it might not come back up
> > without some help. 
> > 
> > So, what can I do to get everything squared away, or should I wait until this evening
> > when I'm back at home to continue this process??
> I've run into the same problem.  To get around it temporarily I just
> moved the sbp2.0 file out of the directory and ran dpkg-reconfigure
> kernel-image-X.X.X-XXX again and it stops complaining.  I originally did
> this so that I could get some modules made with make-kpkg to install
> completely.  I haven't run into any problems by not having that modules,
> but then again I'm not sure exactly what it does.

You can downgrade to the previous version of modutils (2.4.8) or upgrade to
kernel-image-2.4.12. Both solve your problem. It is definitively
a consistency problem among kernel and modutils. Refer to bug#114186.

Francesco P. Lovergine

Reply to: