[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: FYI: intent to NMU to fix SDL + static X extension library problem



On Fri, Oct 05, 2001 at 03:39:51PM -0500, Adam Heath wrote:
> On Fri, 5 Oct 2001, Branden Robinson wrote:
> 
> > [snip]
> 
> All packages linked against sdl will have to modify their build-depends to use
> this new version.  Otherwise, automated compilation tools will not know to
> install the new version of the -dev package, which will not fix the problem.

Good point.

Okay, minor modification:

People who build-depend on (any of) the following packages should
delcare the following Build-Depends:

libgameng-dev		libgameng-dev (>= 3.0-4.1)
libsdl-image1.2-dev	libsdl-image1.2-dev (>= 1.2.0-1.1)
libsdl-mixer1.2-dev	libsdl-mixer1.2-dev (>= 1.2.0-1.1)
libsdl1.2-dev		libsdl1.2-dev (>= 1.2.2-3.1)
libsmpeg-dev		libsmpeg-dev (>= 0.4.4-2.1)

I'll redo my packages of lbreakout and mirrormagic, and also do
burgerspace.  Note that I don't plan to NMU these 3 games unless the
package maintainers want me to.

Again, the place to find this stuff is:

http://hackers.progeny.com/~branden/SDL_OVERHAUL/

-- 
G. Branden Robinson                |       The key to being a Southern
Debian GNU/Linux                   |       Baptist: It ain't a sin if you
branden@debian.org                 |       don't get caught.
http://people.debian.org/~branden/ |       -- Anthony Davidson

Attachment: pgp2Cr6EdQ0pB.pgp
Description: PGP signature


Reply to: