Re: cupsys uprade broken ?
On Fri, Aug 17, 2001 at 05:59:47AM -0500, Colin Watson wrote:
> On Fri, Aug 17, 2001 at 12:01:55PM +0200, christophe barb? wrote:
> > Preparing to replace cupsys 1.1.6-0.1 (using .../cupsys_1.1.9-1.1_i386.deb)
> > ...
> > Stopping CUPSys: cupsd.
> > Unpacking replacement cupsys ...
> > For what I understand, the problem is that cupsys-pstoraster is a new
> > package make of the files previously shipped with the cupsys package. So
> > the cupsys package should be upgraded first. And in fact, after this
> > upgrade a simple
> > apt-get install cupsys-pstoraster
> > solved the problem.
> > It's looks like a packaging bug but before filling a BTS entry I would like
> > to be sure that its possible to specify that one upgrade should be done
> > before an another.
> This should do the job:
> Package: cupsys-pstoraster
> Conflicts: cupsys (<< 1.1.6-0.1)
> Replaces: cupsys (<< 1.1.6-0.1)
Oh, I misread dpkg's output, as that version was the one you were
upgrading *from* (and I've now looked at the changelog too). Try
1.1.8-0.1 instead of 1.1.6-0.1.
Incidentally, can we avoid NMUs with this kind of breakage, please?
Colin Watson [email@example.com]