[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: deps on non-free [Bug#106427: printtool: versioned deps for gs]

On Thu, Jul 26, 2001 at 02:13:29PM +0200, A Mennucc1 <debian@Tonelli.sns.it> spake forth:
> hi
> have received the following bug; may I use
> Depends: lpr-ppd, gs (>= 4.03) | gs-aladdin (>= 4.03), pconf-detect, wish (>=8.0.4) | tk8.0 (>= 8.0.4)  | tk8.2 | tk8.3
> or does this violate the policy as in 2.1.2 ?
> bye & thanks

I agree that having a dep on gs in main *or* gs-aladdin in non-free is fine
for main.

I would like to ask you to please change the tk depends, though:
Depends: tk8.3 | wish

I'd much prefer tk8.3 be the default, and the tk8.0 and 8.2 packages
Provide: wish (the first is so it knows which to install when none of the
others are available. Also, even if you ignore this request, note that
there's no "wish" package and versioned provides don't exist (and don't
generally make sense), so Depends: wish (>=8.0.4) doesn't make much sense

Mike, who's thinking of writing a Tcl/Tk mini-policy at this point... :P

Mike Markley <mike@markley.org>
GPG: 0x3B047084 7FC7 0DC0 EF31 DF83 7313  FE2B 77A8 F36A 3B04 7084

[Doctors and Bartenders], We both get the same two kinds of customers
-- the living and the dying.
- Dr. Boyce, "The Menagerie" ("The Cage"), stardate unknown

Reply to: